Issues with Outlook Friday 7th May 2021 14:04:01


Microsoft are reporting some users are having issues sending from Outlook - we are awaiting further updates on this issue.

Update 17:56 May 12 - These issues should now be resolved, If you are still having problems please contact the IT Service Desk.

Microsoft are again reporting some users are having issues sending from Outlook - we are awaiting further updates on this issue.

Update 17:08 May 10 - These issues should now be resolved, however some users may need to clear their web browser's cookies and cache to fully resolve the issue on their device.

Update 12:25 10 May - Microsoft has confirmed some users are still experiencing issues with sending emails from Outlook this morning. We apologise for any inconvenience this is causing our Keele colleagues.